Comments

post #4930 rob 18/04/2011 04:31 AM:

the porgram works well in root but as soon as a user logs in to his/ or her account
speech-dispatcher does not produces any output
seems like spd-say cant connect to socket
Speech Dispatcher is installed but there is some problem

Speech Dispatcher isn't running or we can't connect to it (see above),
do you want to proceed with other tests? (They can help to determine
Attachment: speechd-debug-17-4-2011.tar.gz (16.18 kB)

post #4932 Hynek Hanke 18/04/2011 11:45 AM:

According to the report you sent us your spd-say client _can_ connect to Speech Dispatcher under your user and manages to have the messages "Speech Dispatcher debugging 1,2,3" synthesized an played on the audio (whether you can hear them in the speakers is another issue).

But you also say that you receive the "Speech Dispatcher isn't running or we can't connect to it" message, which is contradictory. Perhaps from different situation.

Can you please try:
   env SPEECHD_ADDRESS
   spd-say "test"
from command line and tell me what does it write out and whether you hear any sound?

Does your pulse audio produce any sound when used under your user account? You can try with:
   paplay test.wav
where test.wav is any wav file on your disk.

Thanks for your feedback!

post #4960 rob 19/04/2011 06:28 PM:

pulse audio pplay palays the wave files with no problems but "no sound" out of spd-say "test"

 env SPEECHD_ADDRESS
env: SPEECHD_ADDRESS: No such file or directory

i tryed to set the env

rladwig@linux-0fc0:~> export SPEECHD_ADDRESS=unix_socket:/home/rladwig/.speech-dispatcher/speechd.sock
rladwig@linux-0fc0:~> spd-say "test"

nothing happend no sound


rladwig@linux-0fc0:~> export SPEECHD_ADDRESS=/home/rladwig/.speech-dispatcher/speechd.sock
rladwig@linux-0fc0:~> spd-say "test"
Failed to connect to Speech Dispatcher:
Unknown or unsupported communication method




using pulse audio in configuration

rladwig@linux-0fc0:~> spd-conf

Speech Dispatcher configuration tool

Do you want to setup a completely new configuration? [yes] :
>yes
Do you want to create/setup a 'user' or 'system' configuration [user] :
>user
User configuration already exists.
Do you want to rewrite it with a new one? [no] :
>yes
User configuration created in /home/rladwig/.speech-dispatcher/conf
Configuring user settings for Speech Dispatcher
Default output module [espeak] :
>      
Default language (two-letter iso language code like "en" or "cs") [en] :
>
Default audio output method [pulse] :
>
Default speech rate (on the scale of -100..100, 0 is default, 50 is faster, -50 is slower) [0] :
>
Default speech pitch (on the scale of -100..100, 0 is default, 50 is higher, -50 is lower) [0] :
>
Do you want to have Speech Dispatcher automatically started from ~/.config/autostart ?
This is usually not necessary, most applications will start Speech Dispatcher automatically. [no] :
>
Do you want to start/restart Speech Dispatcher now and run some tests? [yes] :
>
Starting Speech Dispatcher in user-mode
[Tue Apr 19 09:34:55 2011 : 880009] speechd: Speech Dispatcher 0.8-dev starting
[Tue Apr 19 09:34:55 2011 : 880087] speechd: Speech Dispatcher already running.

Speech Dispatcher already running.

Can't start Speech Dispatcher. Exited with status 256
Perhaps this is because your Speech Dispatcher is already running.
Do you want to kill all running Speech Dispatchers and try again? [yes] :
>yes
[Tue Apr 19 09:35:00 2011 : 378361] speechd: Speech Dispatcher 0.8-dev starting
Testing Speech Dispatcher using spd_say
Did you hear the message about Speech Dispatcher working? [yes] :
>no
Speech Dispatcher is installed but there is some problem

Speech Dispatcher isn't running or we can't connect to it (see above),
do you want to proceed with other tests? (They can help to determine
what is wrong) [yes] :
>yes
Testing whether Espeak works
Espeak is installed
Testing PULSE sound output
Did you hear the sound? [yes] :
>yes
Audio output 'pulse' works
Testing whether Python Speech Dispatcher library is in path and importable


Diagnostics results:
Speech Dispatcher not working through spd-say
Synthesizers that were tested and seem to work: ['espeak']
Audio systems that were tested and seem to work: ['pulse']
Python Speech Dispatcher module is importable
End of diagnostics results





sppech-dispatcher does not produce any sound if used on regular user account
when used under root, it woorks just fine









using alsa in the configuration




ladwig@linux-0fc0:~/Download> spd-conf

Speech Dispatcher configuration tool

Do you want to setup a completely new configuration? [yes] :
>yes
Do you want to create/setup a 'user' or 'system' configuration [user] :
>user
User configuration already exists.
Do you want to rewrite it with a new one? [no] :
>yes
User configuration created in /home/rladwig/.speech-dispatcher/conf
Configuring user settings for Speech Dispatcher
Default output module [espeak] :
>
Default language (two-letter iso language code like "en" or "cs") [en] :
>
Default audio output method [pulse] :
>alsa
Default speech rate (on the scale of -100..100, 0 is default, 50 is faster, -50 is slower) [0] :
>
Default speech pitch (on the scale of -100..100, 0 is default, 50 is higher, -50 is lower) [0] :
>
Do you want to have Speech Dispatcher automatically started from ~/.config/autostart ?
This is usually not necessary, most applications will start Speech Dispatcher automatically. [no] :
>
Do you want to start/restart Speech Dispatcher now and run some tests? [yes] :
>
Starting Speech Dispatcher in user-mode
[Tue Apr 19 09:24:53 2011 : 933164] speechd: Speech Dispatcher 0.8-dev starting
[Tue Apr 19 09:24:53 2011 : 933242] speechd: Speech Dispatcher already running.

Speech Dispatcher already running.

Can't start Speech Dispatcher. Exited with status 256
Perhaps this is because your Speech Dispatcher is already running.
Do you want to kill all running Speech Dispatchers and try again? [yes] :
>
[Tue Apr 19 09:24:55 2011 : 659441] speechd: Speech Dispatcher 0.8-dev starting
Testing Speech Dispatcher using spd_say
Did you hear the message about Speech Dispatcher working? [yes] :
>no
Speech Dispatcher is installed but there is some problem

Speech Dispatcher isn't running or we can't connect to it (see above),
do you want to proceed with other tests? (They can help to determine
what is wrong) [yes] :
>yes
Testing whether Espeak works
Espeak is installed
Testing ALSA sound output
Playing WAVE '/usr/local/share/sounds/speech-dispatcher/test.wav' : Signed 16 bit Little Endian, Rate 16000 Hz, Mono
Did you hear the sound? [yes] :
>Traceback (most recent call last):
  File "/usr/local/bin/spd-conf", line 10, in <module>
    sys.exit(speechd_config.main())
  File "/usr/local/lib64/python2.7/site-packages/speechd_config/config.py", line 913, in main
    configure.complete_config()
  File "/usr/local/lib64/python2.7/site-packages/speechd_config/config.py", line 856, in complete_config
    output_modules=[self.default_output_module])
  File "/usr/local/lib64/python2.7/site-packages/speechd_config/config.py", line 484, in diagnostics
    if self.test_alsa():
  File "/usr/local/lib64/python2.7/site-packages/speechd_config/config.py", line 433, in test_alsa
    return self.audio_try_play(type='alsa')
  File "/usr/local/lib64/python2.7/site-packages/speechd_config/config.py", line 370, in audio_try_play
    reply = question("Did you hear the sound?", True)
  File "/usr/local/lib64/python2.7/site-packages/speechd_config/config.py", line 60, in question
    str_inp = raw_input(">")
EOFError

terminates with an error on python


for what you told me it seems that speech-dispatcher is working but is failing to output sound
one more intresting pice of information is that if i start the system from my user name, speech-dispacher
wont produce sound enven if i log in as root later on. ex,

user> speech-dispatcher
[Tue Apr 19 10:19:57 2011 : 947652] speechd: Speech Dispatcher 0.8-dev starting
user>spd-say "test"
user>
returns promp but no sound heard!!

user>su
password:xxxxxxxx
root>speech-dispatcher
speechd: Speech Dispatcher 0.8-dev starting
root>spd-say "test"

nothing will happen "no sound" at all but if i start from root since the beginning it will work !!!!!
I dont  understand!!

 

post #4961 rob 19/04/2011 08:08 PM:

ps: updated my pulseaudio pakages and now evrithing works!!!

post #4962 rob 19/04/2011 08:12 PM:

pulseaudio-0.9.22-6.11.1.x86_64 did it for me thanks for your help!

post #4963 Hynek Hanke 20/04/2011 01:15 PM:

 * Řešitel:  -> Hynek Hanke
 * Stav: Nový -> Hotovo
Thank you for your detailed report and sorry for the trouble.

post #4971 rob 21/04/2011 01:06 AM:

no, thanks to all of you guys for all your grate work.
Total records: 7
Note: You need to log in before you can post comments.